Puniko noted in their PR that it may need a yarn cleanall
before building again: FoundKeyGang/FoundKey#385 (comment)
For me it worked without it, but maybe…
Do you have a suggestion for a better name (for future refactoring)?
🔧 I think it would be better if this goes into the config file instead of the database. People should not have to manually edit the database to change configuration.
This should be refactored together with the code from packages/backend/src/queue/processors/inbox.ts
that this was copied from to work out a way that does not duplicate most of the code.
Explicitly checking for something to equal true seems unnecessary, since httpSignature.verifySignature
has the return type boolean
.
This function is always used together with validateFetchSignature
, and the call signature is always handleSignatureResult(ctx, await validateFetchSignature(ctx.req))
. Is there a reason for them being two separate functions?
It could be easier to understand if this was a middleware function that could be added to routes.